lunes, 31 de agosto de 2015

instalar la última versión de povray en Ubuntu 14.04 64 bits

Povray es un trazador de rayos que está disponible para varias plataformas, aunque en las plataformas unix te lo tienes que compilar, sólo tienes que seguir estas instrucciones para conseguirlo:

Compilación e instalación

Primero instalamos las librerías necesarias para la compilación y ejecución:
sudo apt-get install zlib1g-dev libpng12-dev libjpeg-dev libtiff5-dev libopenexr-dev libsdl1.2-dev libboost-system1.55-dev libboost1.55-dev git
Ahora nos descargamos el código fuente:
git clone https://github.com/POV-Ray/povray.git povray
A compilar e instalar:
cd povray/unix
./prebuild.sh
cd ..
./configure COMPILED_BY="tu nombre " LIBS="-lboost_system -lboost_thread"
make
sudo make install
Instalado.

Uso

Ejemplo para generar la imagen a tamaño Full HD

povray -W1920 -H1024 archivo.pov


El archivo pov es un archivo de texto con todas las instrucciones en lenguaje povray para generar la imagen (algunos archivos pov generados por otros programas pueden ser muy grandes).


Se pueden conseguir imágenes sintéticas tan espectaculares como ésta:

2 comentarios:

  1. En Ubuntu 16.04 he instalado povray de los repositorios y me sale el siguiente error:
    povray: error while loading shared libraries: libIlmImf.so.6: cannot open shared object file: No such file or directory

    En la anterior LTS si funcionaba perfectamente.

    ResponderEliminar
    Respuestas
    1. ¿Has instalado previamente todas las librerías necesarias? Prueba con el comando:

      sudo apt-get install libvips-dev libboost-system1.58.0 libboost-thread1.58.0 libc6 libgcc1 libilmbase12 libjpeg8 libopenexr22 libpng12-0 libsdl1.2debian libstdc++6 libtiff5 zlib1g

      Eliminar