miércoles, 8 de febrero de 2012

Blassic, el basic retro para GNU/Linux

Hoy he instalado en mi Ubuntu 10.10 un interprete de Basic que dice tener cierta compatibilidad con los programas hechos para Amstrad CPC, Spectrum, C64, etc... este programa que llama Blassic.
Aunque hay paquetes para Ubuntu, en las nuevas distribuciones no funcionan, por lo que hay que descargarse el código fuente de la última versión y compilarlo, pero tranquilos que son tres comandos:

./configure
make
sudo make install


Y ya lo tienes instalado.
Para ejecutar un programa tecleamos:

blassic programa.bas


Recordad que los programas Basic 1.x del Amstrad CPC no se grababan en modo texto por defecto sino en una codificación especial que no entiende blassic.
Hay que grabarlo con el comando save "programa.bas",a y sacarlo del dsk con algún gestor.

No hay comentarios:

Publicar un comentario